Metasploit SVN Update Error

Heute Nacht noch fix ein SVN Update für Metasploit gemacht und prompt gabs auch einen Fehler, den ich schon lange nicht mehr hatte. Mit dem Update auf 14095 kommt folgender Fehler:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require':
/opt/metasploit3/msf3/lib/msf/core/auxiliary/report.rb:269: syntax error, unexpected '
)' (SyntaxError)
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'

from /opt/metasploit3/msf3/lib/msf/core/auxiliary/mixins.rb:11
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'

from /opt/metasploit3/msf3/lib/msf/core/auxiliary.rb:15
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'

from /opt/metasploit3/msf3/lib/msf/core.rb:51
from /opt/metasploit3/msf3/lib/msf/ui/console/driver.rb:1:in `require'
from /opt/metasploit3/msf3/lib/msf/ui/console/driver.rb:1
from /opt/metasploit3/msf3/lib/msf/ui/console.rb:10:in `require'

from /opt/metasploit3/msf3/lib/msf/ui/console.rb:10
from /opt/metasploit3/msf3/lib/msf/ui.rb:10:in `require'
from /opt/metasploit3/msf3/lib/msf/ui.rb:10
from ./msfconsole:118:in `require'

from ./msfconsole:118

Abhilfe schafft dort ein Uninstall des letzten Updates (14095). Eine Übersicht der letzten Metasploit Revision Updates kann man auf den Seiten von Rapid7 entnehmen. Um aber das Update Problem in den Griff zu bekommen deinstalliert man das letzte SVN Update auf die Revision 14090.

1
svn update -r 14090

Nun sollte Metasploit sich wieder öffnen lassen. Weiter gehts…

Dieser Beitrag wurde unter Metasploit, Security abgelegt und mit , , , , , , , , , verschlagwortet. Setze ein Lesezeichen auf den Permalink.